HLFX.Ru Forum Страницы (3): [1] 2 3 »
Показать все 44 сообщений этой темы на одной странице

HLFX.Ru Forum (http://hlfx.ru/forum/index.php)
- Технические вопросы (http://hlfx.ru/forum/forumdisplay.php?forumid=20)
-- Python 2 или Python 3? (http://hlfx.ru/forum/showthread.php?threadid=5118)


Отправлено XaeroX 08-05-2018 в 16:30:

Python 2 или Python 3?

Как известно некоторым товарищам, недавно мы приняли решение перевести инфраструктуру Volatile и Perilous Warp с bash-скриптов на Python. И возник небольшой спор. Я выбрал Python 2, как более широко распространённый вариант. Пусть и легаси - но зато запустится практически на всех версиях MacOS и Linux из коробки (Windows стоит особняком, там в любом случае придётся ставить Python вручную). Даже в Google используется Python 2 для инфраструктуры...
Но есть и возражения - мол, Python 3 прогрессивнее, быстрее, вот это всё.
А что думаете вы?

__________________
So she began again: 'Où est ma chatte?' which was the first sentence in her French lesson-book. The Mouse gave a sudden leap out of the water, and seemed to quiver all over with fright. 'Oh, I beg your pardon!' cried Alice hastily, afraid that she had hurt the poor animal's feelings. 'I quite forgot you didn't like cats.'


Отправлено Ku2zoff 08-05-2018 в 17:24:

Я в этих ущербных недоязыках недопогроммирования не шарю, если честно. Зачем вплетать это унылое гогно в проект? Чем плохи чистые Си и Си++? Ну и стандартные ср-ва операционок чем вас не устраивают? Для чего петон (то есть говно) вообще нужен вам?

__________________
Вы всё ещё не пьёте? Тогда мы идём к вам!


Отправлено Дядя Миша 08-05-2018 в 17:42:

Перл надо юзать, тут и думоть нечива

__________________
В действительности всё может оказаться иначе, чем оно есть на самом деле

My Projects: download page


Отправлено XaeroX 08-05-2018 в 17:54:

Цитата:
Ku2zoff писал:
Для чего петон вообще нужен вам?

На нём пишется инфраструктура разработки. То есть всевозможные системы сборки, тестирования, обновления и т.д. Использовать С++ для этого слишком дорогостояще, т.к. придётся компилировать программы под каждую платформу (коих у нас пять), да и низкоуровневость в данном случае не нужна и лишь приводит к лишним багам.
Цитата:
Дядя Миша писал:
Перл надо юзать, тут и думоть нечива

Мне вот кажется, что программы на питоне более читабельны, чем на перле.
Как сказал один мудрец - мы пишем код 10% времени, и 90% времени - его читаем.

__________________
So she began again: 'Où est ma chatte?' which was the first sentence in her French lesson-book. The Mouse gave a sudden leap out of the water, and seemed to quiver all over with fright. 'Oh, I beg your pardon!' cried Alice hastily, afraid that she had hurt the poor animal's feelings. 'I quite forgot you didn't like cats.'


Отправлено Дядя Миша 08-05-2018 в 18:11:

Цитата:
XaeroX писал:
Мне вот кажется, что программы на питоне более читабельны

Здесь по традиции надо сослаться на какую-нибудь серъезную контору, которая вот уже ХХ лет юзает перл, но я небуду, сам немаленький, разберёшься. И эта, спонзу довай

__________________
В действительности всё может оказаться иначе, чем оно есть на самом деле

My Projects: download page


Отправлено FiEctro 08-05-2018 в 19:30:

Python 3 прогрессивнее, быстрее, вот это всё.

__________________
Для организации коллектива надо уметь ссать в уши виртуозно (с) Raid


Отправлено nemyax 08-05-2018 в 21:25:

Цитата:
XaeroX писал:
зато запустится практически на всех версиях MacOS и Linux из коробки

Третий на нынешних линуксах тожы запустится без вопросов. Ну только #!/usr/bin/python3 понятное дело.


Отправлено qpAHToMAS 08-05-2018 в 22:33:

Пробовал недавно Python, ужаснулся. А так конечно же 3.


Отправлено nemyax 09-05-2018 в 04:41:

Цитата:
qpAHToMAS писал:
ужаснулся

Хаваешь какой-то левый суп, а виноват, конечно, петон.


Отправлено XaeroX 09-05-2018 в 06:15:

Цитата:
nemyax писал:
Третий на нынешних линуксах тожы запустится без вопросов. Ну только #!/usr/bin/python3 понятное дело.

MacOS Sierra: python3: command not found
MacOS High Sierra: python3: command not found
Debian Jessie (docker): python3: command not found
Это, товарищи, совершенно не смешно.

__________________
So she began again: 'Où est ma chatte?' which was the first sentence in her French lesson-book. The Mouse gave a sudden leap out of the water, and seemed to quiver all over with fright. 'Oh, I beg your pardon!' cried Alice hastily, afraid that she had hurt the poor animal's feelings. 'I quite forgot you didn't like cats.'


Отправлено ~ X ~ 09-05-2018 в 08:29:

Цитата:
XaeroX писал:
недавно мы приняли решение перевести инфраструктуру Volatile и Perilous Warp с bash-скриптов на Python.

/me больше не ждёт волатилу

Да, башскрипты довольно черезжопные, но, всё же, это не ЯП, а командный интерпретатор, как батники в винде. А использовать ЯП для сборки - как-то... слишком навороченно.

PS: Хуже только пёрл.

__________________
Минутка полезного:
Бесплатный UT-подобный Half-Life mod.
Бесплатный редактор для 32-битных текстур. Без дотнета.
Бесплатный IDE для любых компиляторов и ЯП.
Бесплатная Windows-подобная ОС.
Проверка грамматики русского языка.
Связь со мной здесь: [email protected]


Отправлено XaeroX 09-05-2018 в 08:52:

Цитата:
~ X ~ писал:
А использовать ЯП для сборки - как-то... слишком навороченно.

Я не знаю, какой процесс сборки в твоём моде, но у нас это действительно очень сложный процесс с кучей условий, yaml-файлами и прочим.
Да, я написал парсер yaml на баше... Но во-первых, с годами я на такие подвиги буду способен всё реже, а во-вторых, править баги в баш-скриптах такого уровня сложности - развлечение то ещё.

__________________
So she began again: 'Où est ma chatte?' which was the first sentence in her French lesson-book. The Mouse gave a sudden leap out of the water, and seemed to quiver all over with fright. 'Oh, I beg your pardon!' cried Alice hastily, afraid that she had hurt the poor animal's feelings. 'I quite forgot you didn't like cats.'


Отправлено thambs 09-05-2018 в 09:14:

from __future__ import, и явный вызов list() для функций над списками (в 3 они стали ленивыми).

__________________
http://www.moddb.com/mods/monorail-quest


Отправлено XaeroX 09-05-2018 в 11:02:

thambs
Вопрос о том, нужно ли писать Python3-совместимый код, даже не стоит, т.к. ответ очевиден. Ведь рано или поздно всё равно придётся обновиться. Ну хотя бы в тот день, когда python --version начнёт возвращать 3.х не только на свежих линуксах. Но пока-то по дефолту везде 2. Не понимаю, почему вы голосуете на п.2. Потом сами же начнёте ругаться, что мол скачал дев-версию движка и ничего не работает.

__________________
So she began again: 'Où est ma chatte?' which was the first sentence in her French lesson-book. The Mouse gave a sudden leap out of the water, and seemed to quiver all over with fright. 'Oh, I beg your pardon!' cried Alice hastily, afraid that she had hurt the poor animal's feelings. 'I quite forgot you didn't like cats.'


Отправлено qpAHToMAS 09-05-2018 в 13:05:

Цитата:
nemyax писал:
Хаваешь какой-то левый суп, а виноват, конечно, петон.

Что значит левый? Используется стоковый в Python'е html.parser.


Временная зона GMT. Текущее время 20:09. Страницы (3): [1] 2 3 »
Показать все 44 сообщений этой темы на одной странице

На основе vBulletin версии 2.3.0
Авторское право © Jelsoft Enterprises Limited 2000 - 2002.
Дизайн и программирование: Chain Studios © 2005-2018